Author Topic: Hello to fellow NiFe users  (Read 2091 times)

dRdoS7

  • Full Member
  • ***
  • Posts: 138
Hello to fellow NiFe users
« on: April 02, 2017, 08:56:12 PM »
Hi,

As a Solar "Fanatic" (just ask my wife), previously with AGMs, and now (well 4 month badge), a user new to NiFe: I say "Hello" to all other users of NiFe batteries.

LONG MAY THEY RUN!!!! (with minimal electrolyte changes) ;D

dRdoS7

mike90045

  • Hero Member
  • *****
  • Posts: 812
    • The Ranch (via facebook re-direct)
Re: Hello to fellow NiFe users
« Reply #1 on: April 03, 2017, 02:53:24 AM »
Welcome,  been running my set since Oct 2011.  Still doing OK on initial electrolyte .
http://tinyurl.com/LMR-Solar

Classic 200| 2Kw PV, 160Voc | Grundfos 10 SO5-9 with 3 wire Franklin Electric motor (1/2hp 240V 1ph )| Listeroid 6/1, st5 gen head | XW6048 inverter/chgr | midnight ePanel & 4 SPDs | 48V, 800A NiFe battery bank | MS-TS-MPPT60 w/3Kw PV

jmd2020

  • Newby
  • *
  • Posts: 2
Re: Hello to fellow NiFe users
« Reply #2 on: April 03, 2019, 02:19:24 PM »
Hello!

My son has set of 500 Ah cells @ 24V that run his off grid home. They have had 2 electrolyte changes and are now 30 years old. They came from a Chinese company that got bought out by Changhong battery company years ago. They were from a previous customer who had to small of a PV array and thus he thought the battery was bad when all he had to do was charge them up. His loss!

So please do not tell me a nickel iron Chinese battery does not last! They do last if taken care of and sized properly! Some people in this industry say a Chinese nickel iron cell is a piece of crap. Not so! Sure as with anything you can have defective cells or manufacturing defects but t over 30 years of selling nickel iron cells to customers all over the world we have only had  handful of cells that were defective.

John D
BeUtilityFree, Inc

dRdoS7

  • Full Member
  • ***
  • Posts: 138
Re: Hello to fellow NiFe users
« Reply #3 on: September 24, 2020, 02:07:39 AM »
Hi,

This is my goodbye to NiFe post.

I bought mine in 2016, in early 2019 I started seeing some failures (voltage < 0.6, some -0.02) when cells were discharging, and some cells had gunk in the bottom of the case. By early 2020 I was seeing a lot of gunk in the bottom of most cells.

The seller sent me some KOH to make up new electolyte, but after a lot of flushing, and replenishing of 6 cells, I ended up with 2 cells that I could still use, and another 2 that were not so good, but better than nothing. Ended up with a 2 litre container full of gunk.

Efficiency has dropped from near 80% to > 50%, partly due to only using 37 cells, instead of 40, and the higher minimum cell voltage that entails. Also need to charge at a higher voltage to get current into the cells. Using lots of water at the moment!

The seller has agreed to take the cells back, I've already received 50% of my purchase cost, with the other 50% when I return the 40 cells.

Hoping to have them crated up early next week. Luckily, I must have had a premonition, I kept the original crates, which have been used as a table for 4 years.

Seller is arranging collection of the crates, but apparently there's some Dangerous Goods paperwork to be completed first.

I did have 2 1/2 very good years of use. All I needed to do, was the occasional water top up.

The NiFe is dead, long live the LFP!

dRdoS7

« Last Edit: September 24, 2020, 02:12:46 AM by dRdoS7 »

boB

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3385
Re: Hello to fellow NiFe users
« Reply #4 on: September 24, 2020, 03:44:55 AM »

Well that's too bad 😒

I guess not all comes up roses.

You gave it a good try anyway.

Thank you for the report at least.

K7IQ

mike90045

  • Hero Member
  • *****
  • Posts: 812
    • The Ranch (via facebook re-direct)
Re: Hello to fellow NiFe users
« Reply #5 on: September 24, 2020, 12:07:44 PM »
Too bad they failed on you.
 I replaced my electrolyte  a couple years ago
https://www.facebook.com/media/set/?set=a.2113125788760863.1073741849.120212794718849&type=1&l=1988b7f97a
 (the link may work, facebook is shuffling things)
and all has been well since
http://tinyurl.com/LMR-Solar

Classic 200| 2Kw PV, 160Voc | Grundfos 10 SO5-9 with 3 wire Franklin Electric motor (1/2hp 240V 1ph )| Listeroid 6/1, st5 gen head | XW6048 inverter/chgr | midnight ePanel & 4 SPDs | 48V, 800A NiFe battery bank | MS-TS-MPPT60 w/3Kw PV