Author Topic: LCD is Dark ,No Powerup  (Read 147 times)

Masked Frog

  • Newby
  • *
  • Posts: 8
LCD is Dark ,No Powerup
« on: July 03, 2017, 03:52:06 AM »
http://i.imgur.com/CRfy99r.png   

Exactly my issue as per the suport ticket which i'm in a wait/hurry to get answered. Was hoping someone might be able to help me in meantime if its not a dead unit.

Fuses are fine, batterys voltages are fine. Wiring is fine.
Used a meter to test panels and batterys and such already before disconnecting unit to bring him from remote use location.
Am in a rush to get it replaced/fixxed/sorted.
Any idea's? 
Had bought unit nov of last year but had to wait until May of this year to install, and it worked fine for over a month.1

ClassicCrazy

  • Hero Member
  • *****
  • Posts: 1269
Re: LCD is Dark ,No Powerup
« Reply #1 on: July 03, 2017, 10:36:28 AM »
When your Kid was hooked up , did you put the meter also on the output to see if it was charging ?
I am wondering if just the display failed and the rest of the unit is still working ?

Larry
system one
Classic 150 , 20 Kyocera 135watt , 12s Soneil 2v 540amp lead crystal for 24v pack , Outback 3524 inverter
system two
Classic 150 ,5s 135 watt Kyocero , 16s Calb 100AH LiFePO4 , Outback VFX 3648 inverter
system three
Midnite KID MPPT 24 DC in to  12 volt AGM batterie

Masked Frog

  • Newby
  • *
  • Posts: 8
Re: LCD is Dark ,No Powerup
« Reply #2 on: July 03, 2017, 11:01:06 AM »
When your Kid was hooked up , did you put the meter also on the output to see if it was charging ?
I am wondering if just the display failed and the rest of the unit is still working ?

Larry
Both the side LED's and the LCD didn't work. I have a voltage readout hooked up and it was just sitting with no float/equalize or anything.

Westbranch

  • Hero Member
  • *****
  • Posts: 2450
  • Building System (sort of) 1 weekend at a time
Re: LCD is Dark ,No Powerup
« Reply #3 on: July 03, 2017, 11:29:59 AM »
did you hook up the battery first?  If it was the solar that was first you will not have a properly functioning KID or Classic.
CL647 asleep
KID 51(B) FW1811 560W C&D 24V 900Ah AGM
CL 29032 FW V.2126-NW2097-GP2133 175A E-Panel WBjr, 3Px4s 140W > 24V 900Ah AGM,
2 x Cisco WRT54GLi/c DD-WRT Rtr &Brg, NetGr DS104Hub, 
Hughes 1100 Modem
Cotek ST1500 Inv OmniCharge 3024  Eu1/2/3000i Gens
West Chilcotin BC 1680W to come

Masked Frog

  • Newby
  • *
  • Posts: 8
Re: LCD is Dark ,No Powerup
« Reply #4 on: July 03, 2017, 11:33:57 AM »
did you hook up the battery first?  If it was the solar that was first you will not have a properly functioning KID or Classic.
I leave the system setup when i leave camp maintaining the batteries. It was like this when i came back after a week gone.

For troubleshooting i disconnected everything and worked my way thru checking wires breakers and fuses.
Battery was hooked up to unit first.

Westbranch

  • Hero Member
  • *****
  • Posts: 2450
  • Building System (sort of) 1 weekend at a time
Re: LCD is Dark ,No Powerup
« Reply #5 on: July 03, 2017, 11:58:42 AM »
hat being the case START by doing a factory RESET   AFTER turning OFF both Solar and Battery  , press BOTH the , <  and > soft keys together and turn on the battery power...  HOLD the keys DOWN till you see SOLAR on the screen and now set all your charging details...

If this does not work report back to us  what the results are....
CL647 asleep
KID 51(B) FW1811 560W C&D 24V 900Ah AGM
CL 29032 FW V.2126-NW2097-GP2133 175A E-Panel WBjr, 3Px4s 140W > 24V 900Ah AGM,
2 x Cisco WRT54GLi/c DD-WRT Rtr &Brg, NetGr DS104Hub, 
Hughes 1100 Modem
Cotek ST1500 Inv OmniCharge 3024  Eu1/2/3000i Gens
West Chilcotin BC 1680W to come

Masked Frog

  • Newby
  • *
  • Posts: 8
Re: LCD is Dark ,No Powerup
« Reply #6 on: July 03, 2017, 12:02:21 PM »
hat being the case START by doing a factory RESET   AFTER turning OFF both Solar and Battery  , press BOTH the , <  and > soft keys together and turn on the battery power...  HOLD the keys DOWN till you see SOLAR on the screen and now set all your charging details...

If this does not work report back to us  what the results are....
I am not at the install location , but do have the unit and an available 12v battery.

Masked Frog

  • Newby
  • *
  • Posts: 8
Re: LCD is Dark ,No Powerup
« Reply #7 on: July 03, 2017, 12:23:45 PM »
Was a junkie car battery only holding 12.1v but it should have worked for this quick test.
Held Left and right arrow down while connecting to battery. Nothing happens. Held for maybe 10-15 seconds? Then disconnected and tried connecting first then pressing. Same result. Nothing.

ClassicCrazy

  • Hero Member
  • *****
  • Posts: 1269
Re: LCD is Dark ,No Powerup
« Reply #8 on: July 03, 2017, 12:44:02 PM »
hat being the case START by doing a factory RESET   AFTER turning OFF both Solar and Battery  , press BOTH the , <  and > soft keys together and turn on the battery power...  HOLD the keys DOWN till you see SOLAR on the screen and now set all your charging details...

If this does not work report back to us  what the results are....
Westbranch
I know that works for Classic - but does it also work for Kid ? That is what he has . Guess I never tried that with my Kid .

Larry
system one
Classic 150 , 20 Kyocera 135watt , 12s Soneil 2v 540amp lead crystal for 24v pack , Outback 3524 inverter
system two
Classic 150 ,5s 135 watt Kyocero , 16s Calb 100AH LiFePO4 , Outback VFX 3648 inverter
system three
Midnite KID MPPT 24 DC in to  12 volt AGM batterie

KyleM

  • Administrator
  • Newby
  • *****
  • Posts: 23
Re: LCD is Dark ,No Powerup
« Reply #9 on: July 03, 2017, 02:41:52 PM »
hat being the case START by doing a factory RESET   AFTER turning OFF both Solar and Battery  , press BOTH the , <  and > soft keys together and turn on the battery power...  HOLD the keys DOWN till you see SOLAR on the screen and now set all your charging details...

If this does not work report back to us  what the results are....
Westbranch
I know that works for Classic - but does it also work for Kid ? That is what he has . Guess I never tried that with my Kid .

Larry

Just to confrim it Yes, the factory reset works on all of the Classics and the KIDs.

-Kyle

Masked Frog

  • Newby
  • *
  • Posts: 8
Re: LCD is Dark ,No Powerup
« Reply #10 on: July 03, 2017, 03:22:42 PM »
Thanks for trying to help guys. I've ordered a new unit overnight as i need this by the 5th. RMA department was unable to crosship anything.  Looks like ill have a spare for sale soon.

Westbranch

  • Hero Member
  • *****
  • Posts: 2450
  • Building System (sort of) 1 weekend at a time
Re: LCD is Dark ,No Powerup
« Reply #11 on: July 03, 2017, 04:21:34 PM »
Larry, the manual is SADLY LACKING IN HOW TO DO A RESET... I just guessed a few days ago when my neighbour came ovr with all th LEDs  acting like a Roman Candle fireworks display... which has not beenn discussed in the Forum yet...
CL647 asleep
KID 51(B) FW1811 560W C&D 24V 900Ah AGM
CL 29032 FW V.2126-NW2097-GP2133 175A E-Panel WBjr, 3Px4s 140W > 24V 900Ah AGM,
2 x Cisco WRT54GLi/c DD-WRT Rtr &Brg, NetGr DS104Hub, 
Hughes 1100 Modem
Cotek ST1500 Inv OmniCharge 3024  Eu1/2/3000i Gens
West Chilcotin BC 1680W to come

Masked Frog

  • Newby
  • *
  • Posts: 8
Re: LCD is Dark ,No Powerup
« Reply #12 on: July 03, 2017, 04:38:53 PM »
Yes, the manual is very lacking in any troubleshooting. As is the website. When you submit a ticket it lists common problems to choose from to make a ticket for, but no common solutions.
Other than this hiccup, the unit has been everything needed.
Although the length of the run to the panels being suboptimal of 150ft and not facing south. It still provided what i expected.

Westbranch

  • Hero Member
  • *****
  • Posts: 2450
  • Building System (sort of) 1 weekend at a time
Re: LCD is Dark ,No Powerup
« Reply #13 on: July 03, 2017, 06:21:49 PM »
MF please try again pushing FIRMLY on the buttons, it took us 2 trys to get it right..
tks.
CL647 asleep
KID 51(B) FW1811 560W C&D 24V 900Ah AGM
CL 29032 FW V.2126-NW2097-GP2133 175A E-Panel WBjr, 3Px4s 140W > 24V 900Ah AGM,
2 x Cisco WRT54GLi/c DD-WRT Rtr &Brg, NetGr DS104Hub, 
Hughes 1100 Modem
Cotek ST1500 Inv OmniCharge 3024  Eu1/2/3000i Gens
West Chilcotin BC 1680W to come

Masked Frog

  • Newby
  • *
  • Posts: 8
Re: LCD is Dark ,No Powerup
« Reply #14 on: July 03, 2017, 07:21:04 PM »
MF please try again pushing FIRMLY on the buttons, it took us 2 trys to get it right..
tks.
I bottomed them out like a bad tv remote  :P
If the LCD itself was just dead i would assume the side LED's would still work.
« Last Edit: July 03, 2017, 07:27:33 PM by Masked Frog »