Author Topic: Latest KID Beta stuff  (Read 9046 times)

KyleM

  • Administrator
  • Hero Member
  • *****
  • Posts: 1803
Latest KID Beta stuff
« on: August 09, 2018, 03:44:06 PM »
As always we are working to try and make our product work better.

We are working on a new Firmware that will help smooth out some of the data issues we have had in the past and a few more tweaks and updates.
It is all hush hush but it is ready to try.

Just replace the .fup file in your current installer with this one run the installer and you are done.

Please post any weirdness you run into.

REMEMBER  this is beta Firmware

KyleM

ClassicCrazy

  • Hero Member
  • *****
  • Posts: 3278
Re: Latest KID Beta stuff
« Reply #1 on: August 09, 2018, 08:49:32 PM »
Thanks Kyle .

Larry
system one
Classic 150 , 5s4p  Kyocera 135watt , 12s Soneil 2v 540amp lead crystal for 24v pack , Outback 3524 inverter
system two
Classic 150 ,5s 135 watt Kyocero , Jakiper 48v LiFePO4 , Outback VFX 3648 inverter
system three
Midnite KID MPPT 24 DC in to  12 volt AGM batteries

Highflyer

  • Full Member
  • ***
  • Posts: 225
Re: Latest KID Beta stuff
« Reply #2 on: August 11, 2018, 04:21:30 PM »
Are there any new features?

Hopefully Load "on" when the FET or CPU temps rise to a set limit got added.
Brian

The one thing is the one thing

Nomad1

  • Newby
  • *
  • Posts: 22
Re: Latest KID Beta stuff
« Reply #3 on: September 09, 2018, 03:38:50 AM »
Please post any weirdness you run into.

Kyle,
Yesterday I was trying to set something and accidentally switched from PC mode to SYNC in COMM menu. KID was trying to find someone to sync and then it suddenly restarted. KWH/AH were zeroed and since that time ERR led is always on. No other issues found so far.

P.S. What we really need for 1865 firmware is 11th number in PC mode telling what's going on right now: float charging, absorb mode, error, etc. RFR is simply not enough and sometimes stays the same for the whole day.
Programmer

KyleM

  • Administrator
  • Hero Member
  • *****
  • Posts: 1803
Re: Latest KID Beta stuff
« Reply #4 on: September 10, 2018, 11:58:26 AM »
Please post any weirdness you run into.

Kyle,
Yesterday I was trying to set something and accidentally switched from PC mode to SYNC in COMM menu. KID was trying to find someone to sync and then it suddenly restarted. KWH/AH were zeroed and since that time ERR led is always on. No other issues found so far.

P.S. What we really need for 1865 firmware is 11th number in PC mode telling what's going on right now: float charging, absorb mode, error, etc. RFR is simply not enough and sometimes stays the same for the whole day.

I will let Mario know thanks for the input.

-Kyle M

Nomad1

  • Newby
  • *
  • Posts: 22
Re: Latest KID Beta stuff
« Reply #5 on: October 07, 2018, 03:38:11 AM »
Just my 2c about features that'd be great to have in future firmwares:
- current state code in PC Mode - not only "last reason for resting"
- Float on/off signals for AUX output - we need to know that some external stuff should be turned on or off when Kid is burning extra power in float mode
- some kind of time protection for voltage-based Load modes - right now Kid can turn it on and off every second, i.e. when the load consumes few tens of a volt and voltage drops below the threshold and then comes back, triggering the whole thing again

P.S. Right now I have to use whole "Load" output for one simple relay that starts bunch of actions when device enters Float mode: turns off AC input, starts echo charging, report to the statistic server, etc. That's the task for AUX signal generally.

Thanks!
Programmer

Nomad1

  • Newby
  • *
  • Posts: 22
Re: Latest KID Beta stuff
« Reply #6 on: October 10, 2018, 08:22:18 AM »
BUG in 1864: FltMPPT mode is not considered as float for "Float On" load mode! It almost burned my relays when it started switching from Float to FltMTTP several times per second, clicking and blinking CLP LED!
Programmer

KyleM

  • Administrator
  • Hero Member
  • *****
  • Posts: 1803
Re: Latest KID Beta stuff
« Reply #7 on: October 10, 2018, 04:49:44 PM »
BUG in 1864: FltMPPT mode is not considered as float for "Float On" load mode! It almost burned my relays when it started switching from Float to FltMTTP several times per second, clicking and blinking CLP LED!

This has been reported to Mario for review

Kyle

bennyspoon

  • Jr. Member
  • **
  • Posts: 43
Re: Latest KID Beta stuff
« Reply #8 on: December 09, 2018, 09:27:18 PM »
I updated to 1864 last week and everything seemed ok initially. I have 3 controllers in sync, and noticed today some weird things occurring. Reloaded the firmware, but it is still happening. 2 of the controllers have their own solar arrays and the other has no input at the moment.
The 2 solar kids were alternating between one resting and the other working, watts were all over the place, then they both went to resting from absorb,then came back on and were in float.
I then shut everything down and repeated the process several times, each time is a different result. one may go to resting, or the other. often one of them will go to resting and not wake. i can't replicate it to repeat the same outcome.
On one power up, one of the kids was in eq mode,which was not enabled in either the master or slaves.
I am about to load the previous firmware and hope things return to normal.
48v system, 2 solar kids synced{1500w x2 arrays of trina honey 250w}with a 3rd kid synced for hydro f+p 700w turbine{early days!}, classic 150 for 4275w solar ,classic 250/ac clipper for wind {coming} , schneider xw+ 8548 inverter 645ah ex ups exide  jtt12v4800 ,3 strings{fingers crossed}.

bennyspoon

  • Jr. Member
  • **
  • Posts: 43
Re: Latest KID Beta stuff
« Reply #9 on: December 10, 2018, 11:54:38 PM »
Also, I forgot to add that when I did a factory restore  {1864} and re entered the charge settings, I noticed that after I had entered them all and gone back to the battery menu the settings had all gone up by 0.1 volt. At first I thought it was my error but after 5 or so factory restores I realised this was indeed happening.

I have now returned to 1856 firmware and things appear to be working correctly.

The controllers are going to absorb,then they both go to resting and then come back on in float, is this normal?
48v system, 2 solar kids synced{1500w x2 arrays of trina honey 250w}with a 3rd kid synced for hydro f+p 700w turbine{early days!}, classic 150 for 4275w solar ,classic 250/ac clipper for wind {coming} , schneider xw+ 8548 inverter 645ah ex ups exide  jtt12v4800 ,3 strings{fingers crossed}.

scromar

  • Newby
  • *
  • Posts: 6
Re: Latest KID Beta stuff
« Reply #10 on: January 09, 2019, 06:11:42 PM »
Please post any weirdness you run into.

Kyle,
Yesterday I was trying to set something and accidentally switched from PC mode to SYNC in COMM menu. KID was trying to find someone to sync and then it suddenly restarted. KWH/AH were zeroed and since that time ERR led is always on. No other issues found so far.

P.S. What we really need for 1865 firmware is 11th number in PC mode telling what's going on right now: float charging, absorb mode, error, etc. RFR is simply not enough and sometimes stays the same for the whole day.

I had to turn off the controller to get out of COMM Menu using V1860.  I was looking through the menu and wanted to see what prompts where next, I selected the twin mode and it sat there searching not letting me return to another menu. Scott
Houseboat - 1 ReneSola 250W PV, 3 12V 115Ah parallel FLA Store Label (Excide), KID w/WBJR & Shunt, BigBabyBox 3 breakers; 60A (switch) Bat-Bank to House, 30A PV In, & 30A KID to Bat-Bank), 1 Aft & 1 Fwd fused sub-panels, 1@ DeltaVolt Pro 60A PS4 (4-bank) backup charging with AC generator.

Bunkie314

  • Jr. Member
  • **
  • Posts: 58
Re: Latest KID Beta stuff
« Reply #11 on: October 14, 2020, 01:17:44 PM »
Temperature conversion is not correct for CPU and FET in degrees F. Battery temp conversion seems to be correct. I need to correct myself on this statement, its displayed wrong above 100 F. Only 2 digits show up instead of 3. I run the CPU and FET up to over 60 C today and it wasn't giving me the whole number in degrees F.

Unexplainable rebooting of kid during parameter adjustment during operation.

Also as noted in another post twin mode does not work anymore from 1811 FW.
« Last Edit: October 21, 2020, 12:56:12 PM by Bunkie314 »
10-ePVL 136w unisolar panels, 3-lifeline 4D AGM batteries, 2012 Magnasine inverter/charger and two kids on mobile app.

30 Solartech 305w mono awaits remote cabin install

FNG

  • Administrator
  • Sr. Member
  • *****
  • Posts: 404
Re: Latest KID Beta stuff
« Reply #12 on: July 19, 2022, 07:23:15 AM »
New kid code to test, This makes some major improvements in tracking code especially in low light. As always holler if you find anything odd