Author Topic: One Classic 250 MNGP's mirrors the other Classic 250  (Read 263 times)

Trukinbear

  • Newby
  • *
  • Posts: 35
Re: One Classic 250 MNGP's mirrors the other Classic 250
« Reply #15 on: September 14, 2020, 03:09:01 AM »
The repaired unit is the primary so its MODBUS address stays at the default 10, and the other unit is sitting on 11. The SMA COMM MODBUS/Canbus seems to see both of the units where they need to be, and they show up on my Sunny Island as charge controller one, and two, and I can directly read PV Volts, PV Amps, KWh totals and battery voltage from either of the Classic 250s from the Sunny Island, and I can see on the Classics where it says SMA MODE and the charge setpoints have been set by the Sunny Island. At this point this is more of an annoyance than anything else preventing me from seeing WhizBang Jr data while at the Sunny Island. These units (Classic 250V) can operate without a MNGP attached? Just curious.
SMA Solar Sunny Island SI6048
JA Solar 330W 72 cell panels (18)
Classic 250 (2)
MODBUS/Canbus comm adaptor for Sunny Island
SMA-OG E-panel
WhizBang Jr
MNSPD300V (3)
Atkinson GSCM mini-i
Onan Quiet Diesel QD-8000
Monterey 986Ah 'Big Sur' 24-125-11 48V battery
Off the grid on the PNW coast

Trukinbear

  • Newby
  • *
  • Posts: 35
Re: One Classic 250 MNGP's mirrors the other Classic 250
« Reply #16 on: September 14, 2020, 03:12:19 AM »
PS: the last selection on the last screen on the Local App 'CONFIG-TECH' allows changes the MODBUS address - it does work, I've changed it both ways.
SMA Solar Sunny Island SI6048
JA Solar 330W 72 cell panels (18)
Classic 250 (2)
MODBUS/Canbus comm adaptor for Sunny Island
SMA-OG E-panel
WhizBang Jr
MNSPD300V (3)
Atkinson GSCM mini-i
Onan Quiet Diesel QD-8000
Monterey 986Ah 'Big Sur' 24-125-11 48V battery
Off the grid on the PNW coast

boB

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3322
Re: One Classic 250 MNGP's mirrors the other Classic 250
« Reply #17 on: September 14, 2020, 01:25:40 PM »
PS: the last selection on the last screen on the Local App 'CONFIG-TECH' allows changes the MODBUS address - it does work, I've changed it both ways.

Yes, it probably does.  But it is talking to the individual Classic over Ethernet with its own TCP/IP and MAC address.  That is why that works.

Not quite the same over modbus.
K7IQ

Trukinbear

  • Newby
  • *
  • Posts: 35
Re: One Classic 250 MNGP's mirrors the other Classic 250
« Reply #18 on: September 14, 2020, 02:26:14 PM »
Ok, I'm lost now - I didn't have to do anything that was very different than the instructions indicated last year when I set these all up other than figuring out that each Classic had to have it's own ethernet connection as the MODBUS 'network' wasn't really a network they could use for outside communications (to the world). But then both Classics were new and it was a fresh setup. I wish there really WAS a way to reset these to original factory defaults - the VMM with the arrow keys only resets MODE, BAT VOLT, and BAT CAPACITY - and the VMM with the jumpers on the board no better. The units still have all their cumulative totals, voltage targets, unit names, addresses, WhizBang Jr, and network settings the same and aren't cleared. That to me seems to be a big design flaw of some sort. I find it hard to believe these units really can't be reset... but they sure can't be reset with the VMM. I'd love to be able to start from a clean slate, even the 'South' unit that came back from warranty repair was still full of my data, settings, and history (and still knew it's name was South).
SMA Solar Sunny Island SI6048
JA Solar 330W 72 cell panels (18)
Classic 250 (2)
MODBUS/Canbus comm adaptor for Sunny Island
SMA-OG E-panel
WhizBang Jr
MNSPD300V (3)
Atkinson GSCM mini-i
Onan Quiet Diesel QD-8000
Monterey 986Ah 'Big Sur' 24-125-11 48V battery
Off the grid on the PNW coast

boB

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3322
Re: One Classic 250 MNGP's mirrors the other Classic 250
« Reply #19 on: September 14, 2020, 03:51:47 PM »

For the networking using the MNGPs, I would suggest calling tech support and see if they can talk you through that.  One of them should know more about that.

« Last Edit: September 14, 2020, 04:50:18 PM by boB »
K7IQ

Trukinbear

  • Newby
  • *
  • Posts: 35
Re: One Classic 250 MNGP's mirrors the other Classic 250
« Reply #20 on: September 14, 2020, 04:18:57 PM »
What are they walking me thru? As far as the Sunny Island is concerned the network is correct, it is doing what it is supposed to do... what it has always done. I've just got this weird issue where no matter what Classic is connected to MNGP it displays the data from only one of them. I could move the WhizBang Jr to the one that does display and then I wouldn't even give a fart. My fear however is this is a symptom of some upcoming failure, or there is something else that doesn't work right that I just haven't discovered yet. I've already had the networking conversation with them, and Ive got the same flyer that they referred me to last time (last updated in 2013). I'll save that frustration thank you. I appreciate what they do, but phone doesnt seem to be their forte - or it sure wasn't when I called last year. I guess if nobody has ever heard of this happening before, it must be normal? Or nothing? I do appreciate your effort - I guess if one of these IS dieing when it does I'll do a trouble ticket. Thank you
SMA Solar Sunny Island SI6048
JA Solar 330W 72 cell panels (18)
Classic 250 (2)
MODBUS/Canbus comm adaptor for Sunny Island
SMA-OG E-panel
WhizBang Jr
MNSPD300V (3)
Atkinson GSCM mini-i
Onan Quiet Diesel QD-8000
Monterey 986Ah 'Big Sur' 24-125-11 48V battery
Off the grid on the PNW coast

Trukinbear

  • Newby
  • *
  • Posts: 35
Re: One Classic 250 MNGP's mirrors the other Classic 250
« Reply #21 on: September 21, 2020, 01:15:27 PM »
Well crud, the MNGP on the 'West' unit just stopped displaying - unit appears to work, and I don't miss seeing a mirror image display of the 'South' unit. What usually dies next after the MNGP?
SMA Solar Sunny Island SI6048
JA Solar 330W 72 cell panels (18)
Classic 250 (2)
MODBUS/Canbus comm adaptor for Sunny Island
SMA-OG E-panel
WhizBang Jr
MNSPD300V (3)
Atkinson GSCM mini-i
Onan Quiet Diesel QD-8000
Monterey 986Ah 'Big Sur' 24-125-11 48V battery
Off the grid on the PNW coast

FNG

  • Administrator
  • Sr. Member
  • *****
  • Posts: 266
Re: One Classic 250 MNGP's mirrors the other Classic 250
« Reply #22 on: September 21, 2020, 02:13:36 PM »
So the SMA comm adapter requires each connected classic to be addressed.

By default the classics are on ten and the MNGP is on 10. What you have to do is set the upstream Classics and displays to 11,12 and 13 (If you had 4)\

Now if you addressed the classics but NOT the MNGP you would have all MNGPs looking at address 10 so they would all display the same thing in theory.

The issue here is the upstream classics can not see around the loop as there isnt the last loop cable like there is in follow me so it could result in that MNGP showing all 0s

I think what boB was suggesting is you call in to support and walk through this with Todd or Jim and get the adressing set up properly. The fact you are seeing a mirror image tells us the addressing isnt set up correctly

Wizbandit

  • Newby
  • *
  • Posts: 6
Re: One Classic 250 MNGP's mirrors the other Classic 250
« Reply #23 on: September 21, 2020, 02:44:41 PM »
Here is a detailed write-up on Classic Motherboard and MNGP Addressing:
http://www.midniteftp.com/support/kb/faq.php?id=123

Trukinbear

  • Newby
  • *
  • Posts: 35
Re: One Classic 250 MNGP's mirrors the other Classic 250
« Reply #24 on: September 21, 2020, 03:44:23 PM »
So the SMA comm adapter requires each connected classic to be addressed.

By default the classics are on ten and the MNGP is on 10. What you have to do is set the upstream Classics and displays to 11,12 and 13 (If you had 4)\

Now if you addressed the classics but NOT the MNGP you would have all MNGPs looking at address 10 so they would all display the same thing in theory.

The issue here is the upstream classics can not see around the loop as there isnt the last loop cable like there is in follow me so it could result in that MNGP showing all 0s

I think what boB was suggesting is you call in to support and walk through this with Todd or Jim and get the adressing set up properly. The fact you are seeing a mirror image tells us the addressing isnt set up correctly

Yeah, oddly it worked right for a year. That the MGNP doesn't work at all now makes me suspect a potential hardware issue in addition to MNGP addressing. Neither MGNP will display anything (just blank) with either cable on the 'West' unit now... The Sunny Island still sees it, and it's putting out power.
SMA Solar Sunny Island SI6048
JA Solar 330W 72 cell panels (18)
Classic 250 (2)
MODBUS/Canbus comm adaptor for Sunny Island
SMA-OG E-panel
WhizBang Jr
MNSPD300V (3)
Atkinson GSCM mini-i
Onan Quiet Diesel QD-8000
Monterey 986Ah 'Big Sur' 24-125-11 48V battery
Off the grid on the PNW coast