Author Topic: update 1811 problem  (Read 1823 times)

dlnelsonroca

  • Newby
  • *
  • Posts: 10
update 1811 problem
« on: April 02, 2021, 04:20:12 PM »
Hello! I've had my Kid controller in use for several years, and never knew about updates until my controller is no longer working correctly. The message had been with flashing lights and 1811. I went to the midnite solar website, but only found a download for 1864. I downloaded it on my Windows 10 laptop, but got the bootloader 2.5 bad firmware message, and now the thing appears to be locked up. I looked online for an 1811 download without success. What can I do to get it going again? Many thanks!

ClassicCrazy

  • Hero Member
  • *****
  • Posts: 3278
Re: update 1811 problem
« Reply #1 on: April 02, 2021, 07:02:20 PM »
If you go to the page where you downloaded update
at the bottom you will see link for  instructions.
I believe in those instructions it tells you how to fix the problem you are seeing - and all the steps to install firmware properly.
http://www.midnitesolar.com/firmwareReport.php?firmware_ID=21&firmwareProduct_ID=4&act=edit

"If the update process does not complete you might see this error:

BOOTLOADER 2.5
BAD FIRMWARE

You might also see this error on Windows 10 if you tried to update the Firmware without using the Application above. 

If you see this error, power down The KID and wait 60 seconds. Then hold the SETUP button while powering up The KID.  This will put The KID into update mode.  The screen should read:

BOOTLOADER 2.5
FORCED UPDATE

The KID is now ready to retry the firmware update. "

Larry

system one
Classic 150 , 5s4p  Kyocera 135watt , 12s Soneil 2v 540amp lead crystal for 24v pack , Outback 3524 inverter
system two
Classic 150 ,5s 135 watt Kyocero , Jakiper 48v LiFePO4 , Outback VFX 3648 inverter
system three
Midnite KID MPPT 24 DC in to  12 volt AGM batteries

dlnelsonroca

  • Newby
  • *
  • Posts: 10
Re: update 1811 problem
« Reply #2 on: April 03, 2021, 07:13:24 PM »
Thank you! However, I did everything, repowering the unit after a minute off, pressing the setup button, and the forced update message came up. But when I plugged in my laptop that has the 1864 update on it, immediately it goes to the bad update message. I've tried it with the computer already plugged in with the forced update message, then plugged in after the message, etc., and it all does the same. I'm wondering if it requires the 1811 update installed first, but I can't find that update anywhere.

Thanks again for any help you can give me. The system's dead right now!

boB

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3906
Re: update 1811 problem
« Reply #3 on: April 03, 2021, 08:37:55 PM »
Sounds like you need to call into our tech support...

You can try that and leave a message and/or  email them at   support(((AATT)))midnitesolar.com

Who knows ?  Someone might even answer you on the weekend ?   Otherwise you will have to wait until Monday for a reply.

Those guys should know the answer.

K7IQ 🌛  He/She/It

ClassicCrazy

  • Hero Member
  • *****
  • Posts: 3278
Re: update 1811 problem
« Reply #4 on: April 03, 2021, 09:06:56 PM »
Thank you! However, I did everything, repowering the unit after a minute off, pressing the setup button, and the forced update message came up. But when I plugged in my laptop that has the 1864 update on it, immediately it goes to the bad update message. I've tried it with the computer already plugged in with the forced update message, then plugged in after the message, etc., and it all does the same. I'm wondering if it requires the 1811 update installed first, but I can't find that update anywhere.

Thanks again for any help you can give me. The system's dead right now!

It has been awhile since I did update on Kid . Did you try different  usb port for update ? Different usb cable maybe ?  Next thing I would try is a different laptop .

Larry
system one
Classic 150 , 5s4p  Kyocera 135watt , 12s Soneil 2v 540amp lead crystal for 24v pack , Outback 3524 inverter
system two
Classic 150 ,5s 135 watt Kyocero , Jakiper 48v LiFePO4 , Outback VFX 3648 inverter
system three
Midnite KID MPPT 24 DC in to  12 volt AGM batteries

dlnelsonroca

  • Newby
  • *
  • Posts: 10
Re: update 1811 problem
« Reply #5 on: April 05, 2021, 11:37:40 AM »
Well, I tried the different cable, USB port, and laptop. The controller automatically goes to bad firmware as soon as I plug anything in. So I guess I'll try tech support next. Thanks for you suggestions and help so far...

ClassicCrazy

  • Hero Member
  • *****
  • Posts: 3278
Re: update 1811 problem
« Reply #6 on: April 05, 2021, 11:45:13 AM »
Let us know how it turns out .

Larry
system one
Classic 150 , 5s4p  Kyocera 135watt , 12s Soneil 2v 540amp lead crystal for 24v pack , Outback 3524 inverter
system two
Classic 150 ,5s 135 watt Kyocero , Jakiper 48v LiFePO4 , Outback VFX 3648 inverter
system three
Midnite KID MPPT 24 DC in to  12 volt AGM batteries

KyleM

  • Administrator
  • Hero Member
  • *****
  • Posts: 1803
Re: update 1811 problem
« Reply #7 on: April 05, 2021, 12:08:03 PM »
As our forum member ClassicCrazy had stated there is a very specific update process for the KID on Windows 10.

http://www.midnitesolar.com/firmware/kid/MNKID_firmware_1864/KID_Firmware_Upgrade.docx


Please make sure that you have the KID in download mode(or forced download) before your PC is plugged in.

Please make sure that the installer is running on your PC and waiting for the KID to connect.

THEN and only then connect your PC to the KID.


If at that point your KID will not update, it will need to come back to us for repair.

-Kyle

dlnelsonroca

  • Newby
  • *
  • Posts: 10
Re: update 1811 problem
« Reply #8 on: April 09, 2021, 09:25:47 PM »
Hooray! Thank you again. The last by KyleM did it. I had the cable already inserted into the unit and then plugged in the USB. So this time I had the cable in the USB and then plugged it into the unit, and with success. Many thanks. The system is up again.

boB

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3906
Re: update 1811 problem
« Reply #9 on: April 10, 2021, 03:48:07 PM »
Hooray! Thank you again. The last by KyleM did it. I had the cable already inserted into the unit and then plugged in the USB. So this time I had the cable in the USB and then plugged it into the unit, and with success. Many thanks. The system is up again.


WoW !   That's great !

Yes, timing is everything some times.   Shouldn't have to be that way but I am really happy you got it to go !

Thank you Kyle for your wonderful words of wisdom and help on this !

K7IQ 🌛  He/She/It

KyleM

  • Administrator
  • Hero Member
  • *****
  • Posts: 1803
Re: update 1811 problem
« Reply #10 on: April 12, 2021, 12:18:11 PM »
Fantastic!!   Glad we could help. 
-Kyle

dlnelsonroca

  • Newby
  • *
  • Posts: 10
Re: update 1811 problem
« Reply #11 on: April 19, 2021, 01:35:12 PM »
I'm sorry to say that the problem is back, but with a twist. Now the error reads 1864 instead of 1811. After what appeared to be the first successful update, I reset the controller to its original default settings, and not long after the problem began again. I might have to send it to fixed, but I live and work in southern Mexico, making it a pain to do.  How many times should I try to install the 1864 update before I give up?

boB

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3906
Re: update 1811 problem
« Reply #12 on: April 19, 2021, 01:57:53 PM »
I'm sorry to say that the problem is back, but with a twist. Now the error reads 1864 instead of 1811. After what appeared to be the first successful update, I reset the controller to its original default settings, and not long after the problem began again. I might have to send it to fixed, but I live and work in southern Mexico, making it a pain to do.  How many times should I try to install the 1864 update before I give up?


Well, this may actually be a clue !     You updated then did  VMM to reset to defaults.

This might be an extra data point to give another angle to fix it.

What happens if you update the unit yet again but do not reset to default settings but just change them ?
K7IQ 🌛  He/She/It

dlnelsonroca

  • Newby
  • *
  • Posts: 10
Re: update 1811 problem
« Reply #13 on: April 19, 2021, 06:23:54 PM »
That sounds good. But the screen is stuck on BAD FIRMWARE, and won't open anything else.

ClassicCrazy

  • Hero Member
  • *****
  • Posts: 3278
Re: update 1811 problem
« Reply #14 on: April 19, 2021, 07:23:48 PM »
That sounds good. But the screen is stuck on BAD FIRMWARE, and won't open anything else.

Did you try flashing the firmware again ?

Larry
system one
Classic 150 , 5s4p  Kyocera 135watt , 12s Soneil 2v 540amp lead crystal for 24v pack , Outback 3524 inverter
system two
Classic 150 ,5s 135 watt Kyocero , Jakiper 48v LiFePO4 , Outback VFX 3648 inverter
system three
Midnite KID MPPT 24 DC in to  12 volt AGM batteries