Author Topic: Mymidnite2 doesn't work anymore  (Read 169 times)

Nat Hill IV

  • Newby
  • *
  • Posts: 6
Mymidnite2 doesn't work anymore
« on: November 17, 2022, 01:51:48 PM »
I have installed a new router (it's actually part of the AT@T BGE32-500).  I managed to move the static IP for the MidNite Classic somehow and even screwed up the subnet in the process.
BUT I figured all that out.  The Classic pings fine now (at a different static IP address I think).  The midnite solar status program now once again works just fine, as does grham 22's excellent ClassicMonitoring phone app.
But for some odd reason, mymidnite 2 can't seem to locate the Classic.
Have I lost some sort of necessary firewall approval?
I'm lost.
I really like the MyMidnite, because it lets me easily monitor the condition of my battery bank at different times of the day from anywhere.  Or at least it used to!

Any help will be greatly appreciated.
THANKS!

LilMT

  • Jr. Member
  • **
  • Posts: 45
  • Sometimes it works.....
Re: Mymidnite2 doesn't work anymore
« Reply #1 on: November 17, 2022, 04:52:39 PM »
Just out of curiosity have you tried to reboot the classic?  You might want to try it.  Also remember that the time lag may be up to 20 minutes before you see new data at MM2.

I had mine go silly a while back when it lost DHCP for a little while.  A reboot fixed it.  Not certain as to why though.

If a reboot doesn't work, you might look at the FAQ for MM2:

https://mymidnite2.com/?q=node/17

Best of luck and keep us posted.
Thanks,
LilMT

Classic 250, 3s2p Trina Solar 405watt, 8 Renogy 200ah for 48V 400ah, Magnasine 4448 inverter.

Nat Hill IV

  • Newby
  • *
  • Posts: 6
Re: Mymidnite2 doesn't work anymore
« Reply #2 on: November 17, 2022, 06:03:24 PM »
Reset didn't work immediately, but hopefully it will eventually.
I will look at your recommended reading.
Thanks!

Nat Hill IV

  • Newby
  • *
  • Posts: 6
Re: Mymidnite2 doesn't work anymore
« Reply #3 on: November 18, 2022, 09:12:50 AM »
GOT IT!
took a while......
1)   had to discover that in the process of finding an available static address, managed to move the subnet from 255.255.255.0 to 255.255.255.255.  That had killed all monitoring of any source.  When I finally figured that out, the phone app and Solar Status Panel started working, but not MyMidnite2.
2)  finally figured out the AT&T combined "fiber modem", router, and wi-fi had changed lots of things.  Had to tell the Classic that the gateway and primary DNS had changed.
3)  just to follow directions, changed the DNS override as well, although I'm not sure if that had anything to do with it.
4)  told the Class I'm no in Goose Bay to get the time zone right.

ANYWAY, IT"S WORKING PERFECTLY NOW!   :D
THANKS !

LilMT

  • Jr. Member
  • **
  • Posts: 45
  • Sometimes it works.....
Re: Mymidnite2 doesn't work anymore
« Reply #4 on: November 18, 2022, 12:24:15 PM »
Glad it is going for you.  I know I love the MM2 and get distressed when I can't check on the system. :)
Thanks,
LilMT

Classic 250, 3s2p Trina Solar 405watt, 8 Renogy 200ah for 48V 400ah, Magnasine 4448 inverter.